Service Outage Marketplace: Brazil
Incident Report for DocPlanner
Resolved
This incident has been resolved.
Posted Jan 20, 2022 - 00:08 CET
Investigating
We are currently investigating this issue.
Posted Jan 20, 2022 - 00:06 CET