Services outage
Incident Report for DocPlanner
Resolved
This incident has been resolved.
Posted Sep 26, 2022 - 17:02 CEST
Investigating
We are currently investigating this issue.
Posted Sep 26, 2022 - 11:32 CEST
This incident affected: Doctor Websites.