Service Outage Marketplace: Spain
Incident Report for DocPlanner
Resolved
This incident has been resolved.
Posted Jan 19, 2022 - 18:22 CET
Investigating
We are currently investigating this issue.
Posted Jan 19, 2022 - 18:20 CET