Services outage
Incident Report for DocPlanner
Resolved
This incident has been resolved.
Posted Mar 15, 2023 - 07:00 CET
Investigating
We are currently investigating this issue.
Posted Mar 15, 2023 - 06:59 CET
This incident affected: Marketplace (Marketplace: Mexico).